This book is provided freely to you by

EdTechBooks.org

**CC BY:** This work is released under a CC BY license, which means that you are free to do with it as you please as long as you properly attribute it.
# Table of Contents

## Basic Features

- **Book Covers** ................................................................. 5
- **Callouts** ........................................................................ 6
- **Glossaries** ..................................................................... 9
- **Images** ......................................................................... 11
- **Microsoft Word Conversion** ....................................... 16
- **PDF Conversion** .......................................................... 17
- **WYSIWYG Editor** ......................................................... 18

## Advanced Features

- **API** .............................................................................. 20
- **Canvas Embedding** ..................................................... 23
- **Checking Grammar and Spelling** ................................. 24
- **Code Snippets** ............................................................ 25
- **CSS Customization** ..................................................... 26
- **Flights or A/B Testing** .................................................. 27
- **Google Analytics** ........................................................ 28
- **Languages** .................................................................... 29
- **Practice Quizzes** .......................................................... 30
- **Simplified View** ........................................................... 32
- **Synchronization** ........................................................... 33
- **Feature List** ............................................................... 34

## Back Matter

- **Author Information** ...................................................... 37
- **Citation Information** ................................................... 38
Basic Features
Book Covers

The Book Cover Tutorial and Template can be used to create book covers for textbooks. Alternatively, if you want to create your own book cover from scratch, the image should have dimensions equivalent to 5.5 x 8.5 and be less than 1MB in size.

To create a book cover using our template, begin by opening the Google Presentations template. Upon clicking the link, you will open (and copy to your own Google Drive) a document that has been preconfigured to the correct book cover dimensions.

Follow the steps in the tutorial, which are also articulated below:

1. Add text
2. Change fonts
3. Choose a color scheme
4. Select images
5. Select vector graphics
6. Select icons
7. Put it all together
8. Save your cover

The final step is to save the book cover design as a JPEG image. After saving the image to your computer, navigate within EdTech Books to the textbook that you want to add the book cover to. Select the Settings option in the top-right drop-down menu.

Scroll down and upload your new image in the provided area. Your new book cover is now automatically applied to the textbook!
Callouts

Callouts are emphasized boxes of content that you can insert into your chapter to accentuate small blocks of information, such as learning objectives, key takeaways, or a vignette.

To insert a callout while editing a chapter, place your cursor where you would like it placed and go to Tools > Callout Box. The default style will look like this:

**Callout Box**

This is what the "Default" style looks like.

If you would like to change the style of your callout box after it has been inserted, go back to Tools > Callout Box and change the style under Custom Class.

**Alternate Styles**

There are a number of alternate callout styles built into the system. You can apply a custom callout style while inserting the callout by adding the name of the alternate style in the "Custom Class" box. A formatted example of each follows.

**Alternate Style "Positive"**

Select *Positive* as the custom class.

**Alternate Style "Negative"**

Select *Negative* as the custom class.

**Alternate Style "Objectives"**

Select *Objectives* as the custom class.

**Alternate Style "Exercises"**

Select *Exercises* as the custom class.

**Alternate Style "Information"**

Select *Information* as the custom class.
Bootstrap Color Classes

Alternatively, you can also use Bootstrap's color classes to modify either the callout or any of its contents by adding a text-color or bg-color class. Here's an example:

**Heading with the "text-light" and "bg-primary" Classes**

The callout has the "text-primary" and "bg-light" classes added to it.

You can also modify the header directly by placing your cursor on the heading and selecting Formats > Bootstrap Headings. Not all changes will be visible in the WYSIWYG, so you should save the chapter to see the color change.

Custom Formats via CSS

You can also modify the formatting of callout classes across your entire book. In the example below, an additional class was assigned to the callout of "callout-example," and then the following custom CSS was added to the book by going to Advanced > Custom CSS:

```css
#chapter-container div.callout-example { background-color: white; }
#chapter-container div.callout-example h3 { background-color: pink; }
```

**Custom Colors via CSS Override**

Change the custom CSS for the book.

Alternatively, you can also override the look of all callouts in your book by applying a similar custom style to the entire callout class, such as the following:

```css
#chapter-container div.callout { background-color: white; }
#chapter-container div.callout h3 { background-color: pink; }
```

Custom Formats via the Style Attribute

As with any element, you can apply custom formatting to a single callout by editing its "style" attribute in the HTML directly, but this will not propagate to other callouts. An example of doing this to increase the size of the callout's text would be as follows:

```
style="font-size: 1.4em;"
```

**Example Style Editing**

This callout's "style" tag was changed.
**HTML Structure and Headings**

To make a callout, you simply need a div with the class "callout" assigned to it.

Callouts are designed to start with the H3 class as the highest heading (do not use H1 or H2 tags in your callout).

If you include a H3 element as the first element inside the callout, it will be properly formatted as the callout's title (with the top borders rounded and with no spacing at the top). If you wish to include multiple H3 elements inside a single callout, you can fix the rounded corners of subsequent H3 elements by adding the "no-border-radius" class to them.

**Example H3**

Example content goes here.

**Example of H3 with "no-border-radius" class**

Example content goes here.
Glossaries

Each book has a built-in glossary, which may be accessed from the top-right dropdown on the cover page > Glossary.

These glossary terms may be accessed from any chapter, and if you would like to create a chapter for users to see your glossary, then you can do so by adding the Glossary Terms special include in any chapter’s settings.

Creating Glossary Terms

While on your glossary page, you can add new terms using the form at the bottom of the page. Each glossary term requires a name, anchor name, and description as follows:

Name
The human-readable name of the term (e.g., "Project-Based Learning")

Anchor Name
The machine-readable name of the term, which will be used for linking purposes (e.g., "project-based_learning").

Description
The descriptive text for the term. HTML markup is allowed.

Editing Glossary Terms

For any term that is created, click the pencil icon next to it in order to edit.

Creating Glossary Lists within Chapters

You can include an automatically updated list of glossary terms with definitions in any chapter. This is useful if you would like to include a list of key terms within a chapter that will be updated as glossary definitions change.
To do this, edit the chapter, place the cursor where you would like the list placed, and select Tools > Glossary Terms List.

In the Anchors field, type in a comma-separated list of anchors for the book's glossary terms that you would like to have listed, and click Submit.

If you would like to edit the included list later, you can change the terms, delete them, or add new ones directly in the editor.

To update the text that appears in the chapter as glossary terms are changed, simply edit and save the chapter again.

### Creating Glossary Pop-ups

You can create glossary pop-up elements within your chapter by editing the chapter, placing your cursor where you want the pop-up, and choosing Tools > Glossary Link.

Here is an example glossary pop-up: Example Term

### Creating Non-Glossary Pop-Ups

You can also create pop-ups manually by editing the HTML directly, like this one: Example Non-Glossary Pop-up

To do this, use the following code, replacing YOUR DEFINITION HERE and YOUR TEXT HERE with your own.

```html
<span class="glossary-link" role="button" title="YOUR DEFINITION HERE">YOUR TEXT HERE</span>
```
Images

Each book has its own media library that all chapters in the book share. To upload images to the book's media library, navigate to the book's home page and click on the media library button at the top of the page.

When uploading images, be sure that each desired image has a unique name. Uploading an image with the same name as a previously uploaded image will give the new image a new name. If you would like to update an image across an entire book, simply delete the image from the media library first and then upload the updated version with the same name.

Once an image is in the media library, it can be embedded in any chapter by editing the chapter, clicking on the "Insert/edit image" button, and selecting the image's name from the dropdown menu.

Alternatively, if an image is already hosted on another website on the internet, a chapter author can hotlink to it by pasting the image's URL directly into the image embed window. When saving the chapter, if the system detects that the image is hosted on another site, it will attempt to automatically download it and save it on EdTech Books.

Text Wrapping

Because all books created on this site are intended to be mobile-first, and because mobile devices have very small screens, most images you include in your book should fill the entire width. Otherwise, you may have instances where only a couple of words are shown on a single line of text.

However, there might be legitimate times when you have a small image that you do not want to take up the full width of the page (as with the media library icon above). Text wrapping in HTML-speak is done with what is called “floating.” Programmatically, we accomplish this by using some fancy styling that allows the page to change floating options depending upon the size of the page (e.g., floating the image if the width is large [as with a laptop’s web browser], while removing the float if it is small [as with a phone’s web browser]).
To do this in the editor, simply right-click on the image, choose "Image...," and select one of the custom classes from the provided drop-down menu. If you want your image to be on the left of the page and for the text to wrap around it on the right, then choose one of the "Float Left" options. If you want your image to be on the right, then choose one of the "Float Right" options.

Note that the preview in the editor of the text wrapping may not be accurate, so you will want to save the chapter to see how it actually looks.

**Text Wrapping with Captions**

If your image has a caption, then floating becomes even more complicated, because the float must not just apply to the image itself but also to the caption and to their parent element (in HTML-speak, their "figure" element).

This means that if you follow the process above with your image, which applies a float just to the image, then the caption may be on its own—centered on the page or disjointed from the image it's supposed to describe.

To correct this, simply right-click on any image with a caption and choose "Figure...". Then, choose
the desired float option from this drop-down menu instead. Doing so will apply the float to the entire figure (which contains both the image and the caption), as in the example in this section.

You should not apply a float to both an image and its figure at the same time. When you apply a float to the figure (as described here), then it overrides the original float setting on the image, and vice-versa. So, if your image has a caption, simply set the float in the "Figure..." dialog and not the "Image..." dialog.

**Two Floated Images Side-by-Side**

You can place two floated images side-by-side by using the process above, applying a "Float Left" to the first and a "Float Right" to the second. This will show the two images side-by-side on larger screens but will reorganize them to a stacked view on smaller screens. To make this easier, you can also insert two placeholder images by clicking "Tools > HTML Snippets > Side-by-side Images" and then right-clicking each, choosing "Image...," and replacing it with the desired image.
You can test the behavior of the two images above by resizing your screen or by viewing the page on different devices.

**Avoiding Float Overlaps with Clear Fixes**

One final difficulty with floats is that it is not always obvious to the browser what text and other elements should be wrapped around the image and what should not. This can lead to some ugly layouts if you have multiple floated images near one another or don't have enough text following a floated image.

To remedy this, you can insert an invisible element anywhere on the page to tell the HTML to stop the wrapping and to put any new content below it on a fresh, new line. To do this in the editor, simply place your cursor where you want the wrapping to stop and choose "Tools > Clear Fix." This will insert the dashed, green element on your screen below to let you know that all wrapping will stop at that point.
The green indicator is only visible to you in the editor and will not be shown to your reader. This allows you to start a new line of text or even a new floated image on a new line, separate from any previous wrapping introduced by earlier images.
Microsoft Word Conversion

By default, all chapters are available for download as Microsoft Word documents. To download a chapter, navigate to the chapter and append "/ms_word" to the end of the URL.

For example, the URL for this chapter's Microsoft Word download is https://edtechbooks.org/userguide/ms_word/ms_word
PDF Conversion

By default, each chapter in your book and the book itself will build two different PDF files for download: mobile and printable. Mobile PDFs are optimized for tablet viewing, while printable PDFs are optimized for printing on U.S. letter-sized paper.

To make sure that PDFs are enabled on your chapter, while editing your chapter, click on Formatting and ensure that the PDF Rendering option is enabled. A similar option is available when editing the book's main page.

Once PDFs are enabled for your book or chapter, the download link will appear at the bottom of the page. However, PDFs must be built by the server in the background and may not be instantly available. Chapter PDFs generally take several minutes to build (depending on server load), and book PDFs may take a few days. This process can be expedited by the administrator upon request if needed.
WYSIWYG Editor

This site uses the Tiny WYSIWYG editor [https://www.tiny.cloud/] to assist authors in formatting chapter contents.

Alternatively, authors also have the option to edit their chapter's HTML directly by choosing View > Source code within the Tiny editor.
Advanced Features
API

The Reading API for this site allows users and apps to access book and chapter objects in JSON format. The url for the Read API is the site's base url plus "api.php" (e.g., https://edtechbooks.org/api.php).

Two types of objects may be requested via the Read API: (a) a book or (b) a chapter. Book calls require the book variable, which will look up the book based upon the unique "short name" provided. Chapter calls require both the book variable and the chapter variable, which will look up the chapter based upon the unique "short name" for each.

Usage

The API may be used to display content in your own site or app provided that you include proper attribution for the content and the hosting site. This can easily be done by displaying the suggested citation for the book or chapter.

Data Structure

The platform uses three main data object types: authors, books, and chapters. Other objects are also sometimes used, such as glossary terms.

Variables

<table>
<thead>
<tr>
<th>Variable</th>
<th>Type</th>
<th>Status</th>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>action</td>
<td>string</td>
<td>optional</td>
<td>read</td>
<td>Specify the action to be performed. If no action is specified, the API will attempt to return a book or chapter.</td>
</tr>
<tr>
<td>book</td>
<td>string</td>
<td>optional</td>
<td>-</td>
<td>The short name of the book, which is the path of the book's base or cover url. For example: <a href="http://edtechbooks.org/qualitativeinquiry">http://edtechbooks.org/qualitativeinquiry</a></td>
</tr>
<tr>
<td>chapter</td>
<td>string</td>
<td>optional</td>
<td>-</td>
<td>The short name of the chapter, which is the last part of the chapter's url. For example: <a href="http://edtechbooks.org/qualitativeinquiry/storyanalysis">http://edtechbooks.org/qualitativeinquiry/storyanalysis</a></td>
</tr>
<tr>
<td>glossary_term</td>
<td>string</td>
<td>optional</td>
<td>-</td>
<td>The anchor name of the glossary term.</td>
</tr>
<tr>
<td>glossary_term_id</td>
<td>int</td>
<td>optional</td>
<td>-</td>
<td>The term_id of the glossary term.</td>
</tr>
<tr>
<td>term</td>
<td>string</td>
<td>optional</td>
<td>-</td>
<td>Specify a search term for some actions.</td>
</tr>
<tr>
<td>limit</td>
<td>integer</td>
<td>optional</td>
<td>10</td>
<td>Specify a limit. Maximum: 200</td>
</tr>
<tr>
<td>offset</td>
<td>integer</td>
<td>optional</td>
<td>0</td>
<td>Specify an offset for pagination purposes.</td>
</tr>
<tr>
<td>key</td>
<td>string</td>
<td>unused</td>
<td>-</td>
<td>The Reading API currently does not require a key.</td>
</tr>
</tbody>
</table>

Actions

Options for the action variable include the following:

- read (default; requires book; also uses chapter)
- search_authors (requires term)
- search_books (uses term, but returns full list of books if no term is provided)
Examples

To request reference information for all books in the site, the API call would be:

https://edtechbooks.org/api.php?action=search_books&offset=0&limit=200

To request the book object for https://edtechbooks.org/k12handbook, the API call would be:


To request the chapter object for https://edtechbooks.org/k12handbook/connectivism, the API call would be:


To request the glossary term "constructivism" in https://edtechbooks.org/k12handbook, the API call would be:


To search for books with the term "education" in the title, the API call would be:


To search for an author with the name "Royce," the API call would be:

https://edtechbooks.org/api.php?action=search_authors&term=royce

App Structure Example

An example of a simple app that accessed books on this site might follow this structure:

1. A home page that called https://edtechbooks.org/api.php?action=search_books to return all available books (with short names). You can use the offset and limit variables to iterate through the entire list.

An example of an app that could download the entire available database might follow this structure:

1. A home page that called https://edtechbooks.org/api.php?action=search_books to return all available books (with short names). You can use the offset and limit variables to iterate through the entire list.
3. Download each chapter by iterating through the chapter briefs for each book returned in Step 1.
2 via

Authentication

The API currently does not require a key, but that could change as the site and its services develop. For more information on future plans for the API or to request a key, please contact the site administrator.
Canvas Embedding

The following video explains how to embed your textbook into Canvas so that your students can access its contents within the context of your course from the main course navigation.

Essentially, you simply use the LTI-enabled Redirect App within the Canvas interface to create a course navigation link to your book's cover page.

Watch on YouTube https://edtechbooks.org/-uzE

Alternatively, you can also use the Simplified View [https://edtechbooks.org/-SHL] feature to embed a single chapter into a Canvas module.
Checking Grammar and Spelling

EdTech Books does not have a built-in spell- or grammar-checker. Instead, you should either do most of this checking as you write your content on another platform before pasting it into the site (such as Microsoft Word or Google Docs) or use a browser extension such as Grammarly. If you encounter errors in your work after it has been uploaded to EdTech Books, you can use either the WYSIWYG Editor or the inline editing function in the top right corner of your screen. For more details on editing chapters, see Editing a Chapter.
Code Snippets

Code snippets can be displayed on any chapter page by using the "code" style.

# Here is an example block of code using the "Code" style.
var x = 1;
x++;
console.log(x);

To add new lines to the same block of code, hold down Shift while pressing enter to do a soft line break.

Currently, displaying HTML (or any language that uses brackets < >) is not fully supported.
CSS Customization

While editing the book's cover page, you can include custom CSS into the *Custom CSS* field, and this will be applied to all chapters in the book.

This is very powerful and can have undesired effects, because the CSS is applied to the entire page (not just the chapter contents). For instance, including a line like the following

```css
body { color: pink; }
```

would make all text in the book pink, including the author bios and other non-content elements.

To prevent CSS from changing site formatting unexpectedly, you can limit your adjustments to only apply to content within the *article* tag or the *#chapter-container* id as follows:

```css
article h2 { color: pink; }
#chapter-container div.callout h3 { background-color: #6fbada; }
```
Flights or A/B Testing

Flights enable you to conduct A/B or comparative testing on your chapter contents. A chapter flight is a temporary copy of your chapter that your readers can be assigned to (either manually or automatically) so that you can compare reader behaviors based upon small adjustments to the chapter.

For instance, you might want to know whether the inclusion of a particular diagram influences your readers’ ability to answer a practice quiz question correctly. To do this, you would simply (1) add the diagram and practice quiz to your original chapter, (2) create a flight (which copies the chapter), and then (3) edit the resulting flight to remove the diagram. User behaviors for each of the versions will then be tracked separately in the analytics section for each flight.

**Manual Assignment**

Each flight has its own unique URL and QR Code; the URL uses the following pattern:
https://sitedomain/bookname/chaptername/flightnumber

You can manually send users to this flight by sharing it to an email list, on your learning management system, and so forth, but general readers will never be directed to the flight.

**Automatic Assignment**

All readers who view the chapter will be randomly assigned to either the original chapter or one of the flights.
In addition to the default analytics provided for each chapter, each book author may also setup Google Analytics to track information about page visits and users of the book.

To do this, perform the following steps:

1. Create a user account at [Google Analytics](https://analytics.google.com);
2. Create an **Account** and **Property** for your book;
3. Assign the **Property** with the URL of your book (e.g., https://edtechbooks.org/lidtfoundations);
4. In your **Property** settings, find your **Tracking ID** in the tracking code (e.g., UA-XXXXXXXX-X);
5. Copy this **Tracking ID**, and paste it into the **Google Analytics ID** field while editing your book;

After completing these steps, you should be able to access the Google Analytics dashboard for your book and see any active users.

For further help setting up and using Google Analytics (i.e., steps 1-4), please consult the [Google Analytics documentation for developers](https://developers.google.com/analytics).
Languages

Each book and chapter can be identified according to its language by selecting the desired language from the *Language > Content Language* dropdown menu while editing.

Once selected, the book will be listed with other books of the same language on the "Browse Books by Language [https://edtechbooks.org/-jsn]" page.
Practice Quizzes

Practice quizzes can be created within a chapter by placing the cursor where you would like the quiz question and selecting Tools > Practice Quiz.

Enter some text for the question (e.g., “What is the zone of proximal development?”) along with a question ID (e.g., “zpd” or “zone_proximal_development”). The question ID will be used in the analytics so that you can track question responses.

Then, include up to two answer options, like this:

Click “Submit.” You will now see the question with the options in your WYSIWYG editor. You can add more answer options at this point by simply pressing enter after the last option and typing a new one, as follows:

To identify correct answers to the quiz question, simply select the correct option and make it bold as follows:
What is the zone of proximal development?

1. A psychological term
2. A teaching practice
3. A technology integration model

Now, when you save the chapter, the system will format the question appropriately like this:
Simplified View

A simplified view of every textbook chapter is provided to any reader by easily appending the word /simple to the end of any chapter URL.

The simplified view removes site navigation bars and only delivers the chapter content on a plain, white background. This is useful for improving user experiences and stripping away unnecessary distractors.

You can try it by clicking the drop-down menu at the top right of this chapter and choosing “Simple” (or by typing “/simple” at the end of the chapter name in the address bar).

This feature is especially useful if you are embedding chapters into an iframe and do not want readers clicking on navigation items in the book.

For instance, if you are creating a series of course modules in Canvas and want to embed a chapter into Canvas without allowing students to click on other chapters in the textbook or to be confused by the EdTech Books logo, you could simply provide a link to the simplified view of the chapter as an External URL (in this case https://edtechbooks.org/k12handbook/online_safety/simple).
Synchronization

If you imported a chapter from one book to another, you have the option of keeping the child chapter synchronized to its parent. This means that if the original author of the parent chapter updates it, any changes to the content will be synchronized to your imported chapter.

This is useful for boiler plate content or imported content that you do not plan to remix.

- **Parent Chapter**
  - **Active Viewing Guide Template**

- **Synchronize with Parent**
  - Yes, synchronize with parent

If synchronized, all changes made to this chapter will be overwritten by the parent chapter, and whenever the parent chapter is saved, this chapter will be updated as well. Only use this option if you want this chapter’s content to constantly reflect that of the parent chapter.

[Save chapter]
EdTech Books provides various features to authors and readers. This page attempts to provide a comprehensive and organized list of all of these features.

### Content Editing

- Google Docs importer
- Wikipedia article importer
- **Easy WYSIWYG editor** (using TinyMCE)
- Media library
- **LaTeX Equations**
- **Easy image embedding**
- Easy YouTube and Vimeo embedding
- Easy H5P embedding
- HTML source editing
- **CSS overrides for books and chapters**
- Easy chapter importing
- Automatic citation generation
- **Multi-language support**
- **Chapter synchronization**
### Formatting

- Mobile-first, flexible design
- Professional, minimalist aesthetic
- PDF downloads of each book and chapter (mobile- and print-friendly formats)
- MS Word downloads of each chapter
- Simple view of any chapter
- Automatic URL shortening

### Navigation

- Clean (short) URLs (e.g., https://edtechbooks.org/ux)
- Automatic chapter side navigation of headings, images, and tables
- Item-level linking (e.g., each paragraph)
- Automatic QR codes
- Automatic book indices
- Easy embedding into Canvas (and other LMSs)

### Analytics

- End-of-chapter quality surveys
- Reading heat maps

### Advanced Features

- A/B testing via Flights
- Interactive quizzes and surveys
- Chapter narrations
- Cross-site embedding
- Open Read API
- Data analytics on users
- Multi-site, cloud-based hosting
Dr. Royce Kimmons is an Assistant Professor of Instructional Psychology and Technology at Brigham Young University where he studies digital participation divides specifically in the realms of social media, open education, and classroom technology use. More information about his work may be found at http://roycekimmons.com, and you may also dialogue with him on Twitter @roycekimmons.

**CC BY**: This work is released under a CC BY license, which means that you are free to do with it as you please as long as you properly attribute it.